1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Maintainer: Maxime Arthaud <maxime@arthaud.me>
7 pkgdesc='A C++ library to decode QRCode'
9 url='https://github.com/nu-book/zxing-cpp'
14 source=(https://github.com/nu-book/zxing-cpp/archive/v$pkgver/$pkgname-$pkgver.tar.gz
15 https://github.com/zxing-cpp/zxing-cpp/commit/5142600c.patch)
16 sha256sums=('12b76b7005c30d34265fc20356d340da179b0b4d43d2c1b35bcca86776069f76'
17 'bfc575e90fd2ce8d3d45d6a1a3cd1c50c04d206f1f5de31c6bb45f064c295887')
20 patch -d $pkgname-$pkgver -p1 < 5142600c.patch # Fix assert
24 cmake -B build -S $pkgname-$pkgver \
25 -DCMAKE_INSTALL_PREFIX=/usr \
26 -DCMAKE_BUILD_TYPE=None \
27 -DBUILD_EXAMPLES=OFF \
33 ctest --test-dir build --output-on-failure
37 DESTDIR="$pkgdir" cmake --install build