db-move: moved libdmapsharing from [testing] to [extra] (x86_64)
[arch-packages.git] / libdex / trunk / PKGBUILD
blobb9c316f7b3112a40a810b41a60c9997ac769dd6c
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Fabian Bornschein <fabiscafe-cat-mailbox-dog-org>
4 pkgbase=libdex
5 pkgname=(
6   libdex
7   libdex-docs
9 pkgver=0.2.0
10 pkgrel=1
11 pkgdesc="A library supporting 'Deferred Execution'"
12 url="https://gitlab.gnome.org/chergert/libdex"
13 arch=(x86_64)
14 license=(LGPL)
15 depends=(
16   libsoup3
17   liburing
19 makedepends=(
20   gi-docgen
21   git
22   gobject-introspection
23   libsysprof-capture
24   meson
25   vala
27 _commit=c59ec85110954d8e9a1bf31322944225e1dc6874  # tags/0.2.0^0
28 source=("git+https://gitlab.gnome.org/chergert/libdex.git#commit=$_commit")
29 b2sums=('SKIP')
31 pkgver() {
32   cd $pkgbase
33   git describe --tags | sed -r 's/[^-]*-g/r&/;s/-/+/g'
36 prepare() {
37   cd $pkgbase
40 build() {
41   local meson_options=(
42     -D docs=true
43     -D sysprof=true
44   )
46   arch-meson $pkgbase build "${meson_options[@]}"
47   meson compile -C build
50 check() (
51   meson test -C build --print-errorlogs
54 package_libdex() {
55   provides=(libdex-1.so)
57   meson install -C build --destdir "$pkgdir"
59   mkdir -p doc/usr/share
60   mv {"$pkgdir",doc}/usr/share/doc
63 package_libdex-docs() {
64   pkgdesc+=" (documentation)"
65   depends=()
67   mv doc/* "$pkgdir"
70 # vim:set sw=2 sts=-1 et: