db-move: moved libdmapsharing from [testing] to [extra] (x86_64)
[arch-packages.git] / telepathy-glib / trunk / PKGBUILD
blob982efbd4b68b142ee5cfc3328524cda06fc86b51
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Contributor: Ionut Biru <ibiru@archlinux.org>
3 # Contributor: Kessia 'even' Pinheiro <kessiapinheiro at gmail.com
4 # Contributor: Bjorn Lindeijer <bjorn lindeijer nl>
6 pkgname=telepathy-glib
7 pkgver=0.24.2
8 pkgrel=2
9 pkgdesc="GLib bindings for the Telepathy D-Bus protocol"
10 arch=(x86_64)
11 url="https://telepathy.freedesktop.org"
12 license=(LGPL2.1)
13 depends=(dbus-glib)
14 makedepends=(libxslt vala gobject-introspection python)
15 source=(https://telepathy.freedesktop.org/releases/$pkgname/$pkgname-$pkgver.tar.gz{,.asc})
16 sha256sums=('b0a374d771cdd081125f38c3abd079657642301c71a543d555e2bf21919273f0'
17             'SKIP')
18 validpgpkeys=('AA33B0D27868E36C151780F0FE0B6D736B1195ED') # Alexandr Akulich <akulichalexander@gmail.com>
20 build() {
21   cd $pkgname-$pkgver
22   ./configure --prefix=/usr \
23       --libexecdir=/usr/lib/telepathy \
24       --enable-vala-bindings \
25       --enable-static=no
26   make
29 package() {
30   cd $pkgname-$pkgver
31   make DESTDIR="$pkgdir" install