db-move: moved libdmapsharing from [testing] to [extra] (x86_64)
[arch-packages.git] / xorg-xsetroot / trunk / PKGBUILD
blob79432c7a74b60d0790ad7a1d00acb0f548ab1add
1 # Maintainer: Andreas Radke <andyrtr@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=xorg-xsetroot
5 pkgver=1.1.3
6 pkgrel=1
7 pkgdesc="Classic X utility to set your root window background to a given pattern or color"
8 arch=('x86_64')
9 url="https://xorg.freedesktop.org/"
10 license=('custom')
11 depends=('libxmu' 'libx11' 'libxcursor')
12 makedepends=('xorg-util-macros' 'xbitmaps')
13 groups=('xorg-apps' 'xorg')
14 source=(https://xorg.freedesktop.org/archive/individual/app/xsetroot-${pkgver}.tar.xz{,.sig})
15 sha512sums=('f333d1bfd92bb943044da36331ae2cf68a811c8f3891719d9ebc1749e2dd0c67068f86face0794c3c4ae584c4dd189bad4998dccb38fe1ac37a8921e5713e7c0'
16             'SKIP')
17 validpgpkeys=('4A193C06D35E7C670FA4EF0BA2FB9E081F2D130E') # "Alan Coopersmith <alan.coopersmith@oracle.com>"
19 build() {
20   cd xsetroot-${pkgver}
21   ./configure --prefix=/usr
22   make
25 package() {
26   cd xsetroot-${pkgver}
27   make DESTDIR="${pkgdir}" install
28   install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"