archrelease: copy trunk to extra-x86_64
[arch-packages.git] / five-or-more / trunk / PKGBUILD
blobd0863aa90dbd644fd8fb220cd7e3038b831c9a80
1 # Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=five-or-more
5 pkgver=3.32.2
6 pkgrel=1
7 pkgdesc="Remove colored balls from the board by forming lines"
8 url="https://wiki.gnome.org/Apps/Five%20or%20more"
9 arch=(x86_64)
10 license=(GPL)
11 depends=(gtk3 librsvg libgnome-games-support)
12 makedepends=(gobject-introspection yelp-tools appstream-glib git meson vala)
13 groups=(gnome-extra)
14 _commit=8bca9324f02f650e5d8e7206d55e5aaf9c46e28f  # tags/3.32.2^0
15 source=("git+https://gitlab.gnome.org/GNOME/five-or-more.git#commit=$_commit")
16 sha256sums=('SKIP')
18 pkgver() {
19   cd $pkgname
20   git describe --tags | sed 's/-/+/g'
23 prepare() {
24   cd $pkgname
27 build() {
28   arch-meson $pkgname build
29   ninja -C build
32 check() {
33   meson test -C build --print-errorlogs
36 package() {
37   DESTDIR="$pkgdir" meson install -C build