1 # Maintainer: Jan de Groot <jgc@archlinux.org>
2 # Contributor: Ben <ben@benmazer.net>
5 pkgver=2.6.23+4+g91dcee38
7 pkgdesc="A C/C++ MIME creation and parser library with support for S/MIME, PGP, and Unix mbox spools"
10 url="https://github.com/jstedfast/gmime"
11 depends=(glib2 gpgme zlib)
12 makedepends=(gtk-sharp-2 gobject-introspection gtk-doc git vala docbook-utils)
13 _commit=91dcee38ea301463fb9c6bc936f08b9fd1c0969f # gmime-2-6
14 source=("git+https://github.com/jstedfast/gmime#commit=$_commit"
15 0001-Avoid-non-UTF-8-code.patch)
17 '516e339e92e419f5744abfd9b7608816115cca103727755994356b0984edcb10')
21 git describe --tags | sed 's/-/+/g'
26 patch -Np1 -i ../0001-Avoid-non-UTF-8-code.patch
27 NOCONFIGURE=1 ./autogen.sh
31 # get rid of the .wapi errors in fakeroot
33 export MONO_SHARED_DIR="$PWD/weird"
37 ./configure --prefix=/usr \
38 --program-prefix=$pkgname \
44 sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
51 make DESTDIR="$pkgdir" install