archrelease: copy trunk to extra-x86_64
[arch-packages.git] / gmime / trunk / PKGBUILD
blobb25105dd12594cf6b76aff8697011c0c1ca51901
1 # Maintainer: Jan de Groot <jgc@archlinux.org>
2 # Contributor: Ben <ben@benmazer.net>
4 pkgname=gmime
5 pkgver=2.6.23+4+g91dcee38
6 pkgrel=3
7 pkgdesc="A C/C++ MIME creation and parser library with support for S/MIME, PGP, and Unix mbox spools"
8 arch=(x86_64)
9 license=(GPL)
10 url="https://github.com/jstedfast/gmime"
11 depends=(glib2 gpgme zlib)
12 makedepends=(gtk-sharp-2 gobject-introspection gtk-doc git vala docbook-utils)
13 _commit=91dcee38ea301463fb9c6bc936f08b9fd1c0969f  # gmime-2-6
14 source=("git+https://github.com/jstedfast/gmime#commit=$_commit"
15         0001-Avoid-non-UTF-8-code.patch)
16 sha256sums=('SKIP'
17             '516e339e92e419f5744abfd9b7608816115cca103727755994356b0984edcb10')
19 pkgver() {
20   cd gmime
21   git describe --tags | sed 's/-/+/g'
24 prepare() {
25   cd gmime
26   patch -Np1 -i ../0001-Avoid-non-UTF-8-code.patch
27   NOCONFIGURE=1 ./autogen.sh
30 build() {
31   # get rid of the .wapi errors in fakeroot
32   mkdir weird
33   export MONO_SHARED_DIR="$PWD/weird"
35   cd gmime
37   ./configure --prefix=/usr \
38     --program-prefix=$pkgname \
39     --enable-gtk-doc \
40     --enable-mono \
41     --enable-smime \
42     --disable-static
44   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
46   make
49 package() {
50   cd gmime
51   make DESTDIR="$pkgdir" install