archrelease: copy trunk to extra-x86_64
[arch-packages.git] / gnome-weather / repos / extra-any / PKGBUILD
blobde53c4d14aa713606959f2a42ac2f09382e6394e
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgname=gnome-weather
4 pkgver=41.0
5 pkgrel=1
6 pkgdesc="Access current weather conditions and forecasts"
7 url="https://wiki.gnome.org/Apps/Weather"
8 arch=(any)
9 license=(GPL)
10 depends=(gtk3 gjs libgweather geoclue2 gnome-desktop libhandy)
11 makedepends=(gobject-introspection appstream-glib git meson)
12 groups=(gnome)
13 _commit=8eea7b1727c2b657e119f8729d7ebef77480326d  # tags/41.0^0
14 source=("git+https://gitlab.gnome.org/GNOME/gnome-weather.git#commit=$_commit")
15 sha256sums=('SKIP')
17 pkgver() {
18   cd $pkgname
19   git describe --tags | sed 's/-/+/g'
22 prepare() {
23   cd $pkgname
26 build() {
27   arch-meson $pkgname build
28   meson compile -C build
31 check() {
32   meson test -C build --print-errorlogs
35 package() {
36   meson install -C build --destdir "$pkgdir"