archrelease: copy trunk to extra-x86_64
[arch-packages.git] / libetonyek / trunk / PKGBUILD
blob71c55f259ff7acdcb08c27952e4db694cf0e8792
1 # Maintainer: AndyRTR <andyrtr@archlinux.org>
2 # Maintainer:  BartÅ‚omiej Piotrowski <bpiotrowski@archlinux.org>
3 # Contributor: Yue
5 pkgname=libetonyek
6 pkgver=0.1.10
7 pkgrel=1
8 pkgdesc='Library and a set of tools for reading and converting Apple Keynote presentations'
9 arch=('x86_64')
10 url="https://wiki.documentfoundation.org/DLP/Libraries/libetonyek"
11 license=('MPL')
12 depends=('libxml2' 'zlib' 'libwpd' 'boost-libs' 'librevenge' 'liblangtag')
13 makedepends=('boost' 'cppunit' 'gperf' 'doxygen' 'glm' 'mdds')
14 source=(https://dev-www.libreoffice.org/src/$pkgname/$pkgname-$pkgver.tar.xz)
15 sha256sums=('b430435a6e8487888b761dc848b7981626eb814884963ffe25eb26a139301e9a')
17 build() {
18   cd $pkgname-$pkgver
19   ./configure --prefix=/usr --with-mdds=1.5
20   make
23 check() {
24   cd $pkgname-$pkgver
25   make check
28 package() {
29   cd $pkgname-$pkgver
30   make DESTDIR="$pkgdir" install