1 # Maintainer: Ronald van Haren <ronald.archlinux.org>
2 # Contributor: Angelo Theodorou <encelo@users.sourceforge.net>
3 # Contributor: Vinay S Shastry <vinayshastry@gmail.com>
8 pkgdesc="A wxWidgets GUI for the computer algebra system Maxima"
10 url="https://wxmaxima-developers.github.io/wxmaxima/"
12 depends=('maxima' 'wxgtk3')
14 source=($pkgname-$pkgver.tar.gz::"https://github.com/wxMaxima-developers/wxmaxima/archive/Version-${pkgver}.tar.gz")
15 sha256sums=('167e412708e1ef6f68fe934e55844af25a6d4e6f176eb26d46858576b17a90dd')
18 cmake -B build -S ${pkgname}-Version-${pkgver} \
19 -DCMAKE_INSTALL_PREFIX=/usr \
20 -DwxWidgets_CONFIG_EXECUTABLE=/usr/bin/wx-config-gtk3
25 # cd ${pkgname}-Version-${pkgver}
26 # ./src/wxmaxima test/testbench_simple.wxmx
30 DESTDIR="${pkgdir}" cmake --install build