2.42.9-1
[arch-packages.git] / epiphany / trunk / PKGBUILD
blob55dae7b79b53f283c1ad7c47fff9766a1b2b4a94
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=epiphany
5 pkgver=42.4
6 pkgrel=1
7 pkgdesc="A GNOME web browser based on the WebKit rendering engine"
8 url="https://wiki.gnome.org/Apps/Web"
9 arch=(x86_64)
10 license=(GPL)
11 depends=(webkit2gtk-4.1 gcr icu libdazzle libhandy libarchive libportal-gtk3)
12 makedepends=(docbook-xml startup-notification lsb-release gobject-introspection
13              yelp-tools git meson)
14 checkdepends=(xorg-server-xvfb aspell hspell hunspell nuspell libvoikko)
15 groups=(gnome)
16 options=(debug)
17 _commit=a904a30bfe911e000d6263f338f99cf20b66ad97  # tags/42.4^0
18 source=("git+https://gitlab.gnome.org/GNOME/epiphany.git#commit=$_commit")
19 sha256sums=('SKIP')
21 pkgver() {
22   cd epiphany
23   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
26 prepare() {
27   cd epiphany
30 build() {
31   arch-meson epiphany build -D soup2=disabled
32   meson compile -C build
35 check() {
36   dbus-run-session xvfb-run -s '-nolisten local' \
37     meson test -C build --print-errorlogs
40 package() {
41   meson install -C build --destdir "$pkgdir"