2.42.9-1
[arch-packages.git] / glew / trunk / PKGBUILD
blob9b972836b9995b2bce78001fa3650b34c9b0f99b
1 # Maintainer: Andreas Radke <andyrtr@archlinux.org>
2 # Contributor: Stéphane Gaudreault <stephane@archlinux.org>
3 # Contributor: SleepyDog
5 pkgname=glew
6 pkgver=2.2.0
7 pkgrel=3
8 pkgdesc="The OpenGL Extension Wrangler Library"
9 arch=('x86_64')
10 url="https://github.com/nigels-com/glew"
11 license=('BSD' 'MIT' 'GPL')
12 depends=('libxmu' 'libxi' 'glu')
13 provides=('libGLEW.so')
14 options=('debug')
15 # https://sourceforge.net/projects/glew/files/glew/
16 source=(https://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}.tgz
17         glew-install.patch)
18 sha1sums=('22d6e9b9e691080eb6313407dbf51cfebc3345ea'
19           'e1bfa1e6ae3c7a553920978111092ea9d3a33c95')
21 prepare() {
22   cd ${pkgname}-${pkgver}
23   patch -Np1 -i ../glew-install.patch
26 build() {
27   cd ${pkgname}-${pkgver}
28   make \
29    STRIP= \
30    LIBDIR=/usr/lib
33 package() {
34   cd ${pkgname}-${pkgver}
35   make install.all DESTDIR="$pkgdir" \
36     LIBDIR=/usr/lib
37   install -D -m644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"