2.42.9-1
[arch-packages.git] / libde265 / trunk / PKGBUILD
blob898c27c1065ff7f60c5a82715296ff8cca9759a2
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Contributor: James An <james@jamesan.ca>
3 # Contributor: Daniel Nagy <danielnagy at gmx de>
5 pkgname=libde265
6 pkgver=1.0.8
7 pkgrel=2
8 pkgdesc="Open h.265 video codec implementation"
9 arch=(x86_64)
10 url="https://github.com/strukturag/libde265"
11 license=(LGPL3)
12 depends=(gcc-libs)
13 makedepends=(ffmpeg sdl qt5-base)
14 optdepends=('ffmpeg: for sherlock265' 'qt5-base: for sherlock265'
15             'sdl: dec265 YUV overlay output')
16 source=(https://github.com/strukturag/libde265/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz)
17 sha256sums=('24c791dd334fa521762320ff54f0febfd3c09fc978880a8c5fbc40a88f21d905')
19 build() {
20   cd $pkgname-$pkgver
21   ./configure --prefix=/usr --enable-static=no
22   make
25 package() {
26   cd $pkgname-$pkgver
27   make DESTDIR="$pkgdir" install
29 # Remove useless tests binary
30   rm "$pkgdir"/usr/bin/tests