2.42.9-1
[arch-packages.git] / libdmapsharing / trunk / PKGBUILD
blobb1ed2f01592db82323c8ee163f937541a7c94404
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Ionut Biru <ibiru@archlinux.org>
4 pkgname=libdmapsharing
5 pkgver=2.9.41
6 pkgrel=1
7 pkgdesc="A library that implements the DMAP family of protocols"
8 url="https://www.flyn.org/projects/libdmapsharing/index.html"
9 arch=(x86_64)
10 license=(LGPL2.1)
11 depends=(libsoup avahi gst-plugins-base-libs gdk-pixbuf2)
12 makedepends=(git gtk-doc gobject-introspection check vala)
13 options=(debug)
14 _commit=ecee3cc737d748d45ef4524b2c19a0fdf7c73804  # tags/LIBDMAPSHARING_2_9_41^0
15 source=("git+https://gitlab.gnome.org/GNOME/libdmapsharing.git#commit=$_commit")
16 sha256sums=('SKIP')
18 pkgver() {
19   cd $pkgname
20   git describe --tags | sed 's/^LIBDMAPSHARING_//;s/_/./g;s/[^-]*-g/r&/;s/-/+/g'
23 prepare() {
24   cd $pkgname
25   NOCONFIGURE=1 ./autogen.sh
28 build() {
29   cd $pkgname
30   ./configure --prefix=/usr --with-mdns=avahi --enable-gtk-doc
31   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
32   make
35 package() {
36   cd $pkgname
37   make DESTDIR="$pkgdir" install