1 # Maintainer: David Runge <dvzrv@archlinux.org>
7 pkgdesc="Extended version of the PMI standard"
9 url="https://github.com/openpmix/openpmix"
11 depends=(curl glibc hwloc jansson libevent zlib)
12 makedepends=(perl python)
13 provides=(libpmix.so pmix)
14 backup=(etc/$pkgname/pmix-mca-params.conf)
16 # unable to build from auto-generated tarball because build system is
17 # configured to only generate required files when in a git repository:
18 # https://github.com/openpmix/openpmix/issues/2599
19 # source=($pkgname-$pkgver.tar.gz::https://github.com/$pkgname/$pkgname/archive/refs/tags/v$pkgver.tar.gz)
20 source=($pkgname-$pkgver.tar.gz::https://github.com/$pkgname/$pkgname/releases/download/v$pkgver/pmix-$pkgver.tar.gz)
21 sha512sums=('aff153ab976f85355fd0241374c32fe86fc508c2921769e1e89ba1c4dc522a0e48c346eb6f9f1386c1e92261e348824b4d0062544069246b1a83037f47680d04')
22 b2sums=('8595ee23927651770eebdd16a850ae4acdddc64065d9f64ab71399b0b0f04908407e4cc557a8ab8c79750f8e239572b809e2b8705ed264c900ac1dad16f7d68b')
33 --sysconfdir=/etc/$pkgname \
36 # prevent excessive overlinking due to libtool
37 sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
42 make -k check -C $_name-$pkgver
48 make DESTDIR="$pkgdir" install -C $_name-$pkgver
49 install -vDm 644 $_name-$pkgver/LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"