1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Maintainer: Felix Yan <felixonmars@archlinux.org>
4 pkgname=qt6-positioning
9 url='https://www.qt.io'
10 license=(GPL3 LGPL3 FDL custom)
11 pkgdesc='Provides access to position, satellite and area monitoring classes'
13 makedepends=(cmake ninja qt6-declarative qt6-serialport)
14 optdepends=('qt6-declarative: QML bindings' 'qt6-serialport: NMEA plugin')
15 conflicts=(qt6-location)
16 provides=(qt6-location)
17 replaces=(qt6-location)
20 _pkgfn=${pkgname/6-/}-everywhere-src-$_qtver
21 source=(https://download.qt.io/official_releases/qt/${pkgver%.*}/$_qtver/submodules/$_pkgfn.tar.xz)
22 sha256sums=('06788e4ecae1920094b30e4046f0abd23c8189d8a51e9c939b02f0b6abe2e86c')
25 cmake -B build -S $_pkgfn -G Ninja
30 DESTDIR="$pkgdir" cmake --install build
32 install -d "$pkgdir"/usr/share/licenses
33 ln -s /usr/share/licenses/qt6-base "$pkgdir"/usr/share/licenses/$pkgname