2.42.9-1
[arch-packages.git] / xdg-desktop-portal-gtk / trunk / PKGBUILD
blobec01bbfc13fdab45b593ec4ecbee90a4582484a0
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: BartÅ‚omiej Piotrowski <bpiotrowski@archlinux.org>
3 # Contributor: Patrick Griffis <tingping@tingping.se>
5 pkgname=xdg-desktop-portal-gtk
6 pkgver=1.14.0
7 pkgrel=1
8 pkgdesc="A backend implementation for xdg-desktop-portal using GTK"
9 url="https://github.com/flatpak/xdg-desktop-portal-gtk"
10 arch=(x86_64)
11 license=(LGPL)
12 depends=(gtk3 gsettings-desktop-schemas)
13 makedepends=(xdg-desktop-portal python git)
14 optdepends=("evince: Print preview")
15 provides=(xdg-desktop-portal-impl)
16 options=(debug)
17 _commit=7c7bbf922b63b9d536a2293c0587cb20df01eb2d  # tags/1.14.0
18 source=("git+https://github.com/flatpak/xdg-desktop-portal-gtk#commit=$_commit")
19 sha256sums=('SKIP')
21 pkgver() {
22   cd $pkgname
23   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
26 prepare() {
27   cd $pkgname
28   NOCONFIGURE=1 ./autogen.sh
31 build() {
32   cd $pkgname
33   ./configure --prefix=/usr --libexecdir=/usr/lib
34   make 
37 check() {
38   cd $pkgname
39   make check
42 package() {
43   cd $pkgname
44   DESTDIR="$pkgdir" make install