2.42.9-1
[arch-packages.git] / xf86-video-ati / trunk / PKGBUILD
blob57d9bf7e4eacdfd99130dc60b945dc56333e8b94
1 # Maintainer: AndyRTR <andyrtr@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
3 # Contributor: Alexander Baldeck <alexander@archlinux.org>
5 pkgname=xf86-video-ati
6 _commit=5eba006e4129e8015b822f9e1d2f1e613e252cda
7 pkgver=19.1.0.r9.g5eba006e
8 pkgrel=2
9 epoch=1
10 pkgdesc="X.org ati video driver"
11 arch=('x86_64')
12 url="https://xorg.freedesktop.org/"
13 license=('custom')
14 depends=('systemd-libs' 'mesa')
15 makedepends=('xorg-server-devel' 'systemd' 'X-ABI-VIDEODRV_VERSION=25.2' 'git')
16 conflicts=('xorg-server<21.1.1' 'X-ABI-VIDEODRV_VERSION<25' 'X-ABI-VIDEODRV_VERSION>=26')
17 groups=('xorg-drivers')
18 #source=(${url}/releases/individual/driver/${pkgname}-${pkgver}.tar.bz2{,.sig})
19 #sha512sums=('73a81f6c492daf2e89067fb52b3033dc0fe6841f109627ddca1aee54a45a738c8c134443753a2a2aaa2c131e1d560057ebc76351ff2304c16407df3ff568fcd6'
20 #            'SKIP')
21 source=("${pkgname}-${pkgver}::git+https://gitlab.freedesktop.org/xorg/driver/xf86-video-ati#commit=${_commit}"
22         0001_dont_set_sourcevalidate_pointer_to_null.diff)
23 sha512sums=('SKIP'
24             'ca7c769a20e0682ca0122a8248fa79a54d2181d9554c93174a3c49638b6810951787ed5e5e7f7e0f6d091ce2a111aee4bd03108ef74af95ebea340bc0300480f')
25 validpgpkeys=('B09FAF35BE914521980951145A81AF8E6ADBB200') # Michel Daenzer <michel@daenzer.net>
27 pkgver() {
28   cd ${pkgname}*
29   # from ati-git AUR pkg
30   git describe --long | sed 's/^xf86-video-ati-//;s/\([^-]*-g\)/r\1/;s/-/./g'
34 prepare() {
35   cd ${pkgname}*
37   # fix a crash under Xorg-server 21.1.1
38   # https://bugs.archlinux.org/task/72759
39   # https://gitlab.freedesktop.org/xorg/driver/xf86-video-ati/-/merge_requests/9
40   patch -Np1 -i ../0001_dont_set_sourcevalidate_pointer_to_null.diff
42   NOCONFIGURE=1 ./autogen.sh
45 build() {
46   cd ${pkgname}* #-${pkgver}
48 #  CFLAGS+=' -fcommon' # https://wiki.gentoo.org/wiki/Gcc_10_porting_notes/fno_common
50   # Since pacman 5.0.2-2, hardened flags are now enabled in makepkg.conf
51   # With them, module fail to load with undefined symbol.
52   # See https://bugs.archlinux.org/task/55102 / https://bugs.archlinux.org/task/54845
53   export CFLAGS=${CFLAGS/-fno-plt}
54   export CXXFLAGS=${CXXFLAGS/-fno-plt}
55   export LDFLAGS=${LDFLAGS/,-z,now}
57   ./configure --prefix=/usr
58   make
61 check() {
62   cd ${pkgname}* #-${pkgver}
63   make check
66 package() {
67   cd ${pkgname}* #-${pkgver}
69   make "DESTDIR=${pkgdir}" install
70   install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
71   install -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/"