1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Maintainer: Felix Yan <felixonmars@archlinux.org>
4 pkgname=qt6-remoteobjects
9 url='https://www.qt.io'
10 license=(GPL3 LGPL3 FDL custom)
11 pkgdesc='Inter-process communication (IPC) module developed for Qt'
13 makedepends=(cmake ninja qt6-declarative)
14 optdepends=('qt6-declarative: QML bindings')
17 _pkgfn=${pkgname/6-/}-everywhere-src-$_qtver
18 source=(https://download.qt.io/development_releases/qt/${pkgver%.*}/$_qtver/submodules/$_pkgfn.tar.xz)
19 sha256sums=('067bd68ee5a76c5089aa400e1998bb3a85ae824bdcc814f1bbd7cf797a82dad0')
22 cmake -B build -S $_pkgfn -G Ninja \
23 -DCMAKE_MESSAGE_LOG_LEVEL=STATUS
28 DESTDIR="$pkgdir" cmake --install build
30 install -d "$pkgdir"/usr/share/licenses
31 ln -s /usr/share/licenses/qt6-base "$pkgdir"/usr/share/licenses/$pkgname