OCaml 4.14.0 rebuild
[arch-packages.git] / audacious / trunk / PKGBUILD
blobf334ed640d0980f1b183be1b841e8a39b890367f
1 # Maintainer: Evangelos Foutras <evangelos@foutrelis.com>
2 # Contributor: Gaetan Bisson <bisson@archlinux.org>
3 # Contributor: Alexander Fehr <pizzapunk gmail com>
4 # Contributor: Giovanni Scafora <giovanni@archlinux.org>
6 pkgname=audacious
7 pkgver=4.2
8 pkgrel=1
9 pkgdesc="Lightweight, advanced audio player focused on audio quality"
10 arch=('x86_64')
11 url="https://audacious-media-player.org/"
12 license=('BSD')
13 depends=('qt5-base' 'qt5-svg' 'glib2' 'libguess' 'libsm' 'audacious-plugins'
14          'hicolor-icon-theme' 'desktop-file-utils')
15 makedepends=('python') # for gdbus-codegen
16 optdepends=('unzip: zipped skins support')
17 source=(https://distfiles.audacious-media-player.org/$pkgname-$pkgver.tar.bz2)
18 sha256sums=('feb304e470a481fe2b3c4ca1c9cb3b23ec262540c12d0d1e6c22a5eb625e04b3')
20 build() {
21   cd "$srcdir/$pkgname-$pkgver"
23   ./configure \
24     --prefix=/usr \
25     --disable-gtk \
26     --with-buildstamp='Arch Linux'
27   make
30 package() {
31   cd "$srcdir/$pkgname-$pkgver"
32   make DESTDIR="$pkgdir" install
33   install -Dm644 contrib/audacious.appdata.xml -t "$pkgdir/usr/share/metainfo"
34   install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
37 # vim:set ts=2 sw=2 et: