OCaml 4.14.0 rebuild
[arch-packages.git] / bc / trunk / PKGBUILD
blob36b56852ae4be8561e390ee71893c6d4735e7def
1 # Maintainer: dorphell <dorphell@archlinux.org>
3 pkgname=bc
4 pkgver=1.07.1
5 pkgrel=4
6 pkgdesc="An arbitrary precision calculator language"
7 arch=('x86_64')
8 url="https://www.gnu.org/software/bc/"
9 license=('GPL')
10 depends=('readline')
11 makedepends=('ed')
12 replaces=('bc-readline')
13 conflicts=('bc-readline')
14 source=(https://ftp.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.gz{,.sig})
15 sha256sums=('62adfca89b0a1c0164c2cdca59ca210c1d44c3ffc46daf9931cf4942664cb02a'
16             'SKIP')
17 validpgpkeys=('00E426232F384BF6D32D8B1881C24FF12FB7B14B') # Phil Nelson <philnelson@acm.org>
19 build() {
20   cd "${pkgname}-${pkgver}"
21   ./configure --prefix=/usr --mandir=/usr/share/man \
22     --infodir=/usr/share/info --with-readline
23   make -j1
26 check () {
27   cd "${pkgname}-${pkgver}"
28   echo "quit" | ./bc/bc -l Test/checklib.b
31 package() {
32   cd "${pkgname}-${pkgver}"
33   make DESTDIR="${pkgdir}" install