OCaml 4.14.0 rebuild
[arch-packages.git] / claws-mail / repos / extra-x86_64 / PKGBUILD
blob419035e9509211951da2b6eac5a77ff9755050d6
1 # Maintainer: Andreas Radke <andyrtr@archlinux.org>
3 pkgname=claws-mail
4 pkgver=4.1.0
5 pkgrel=2
6 pkgdesc="A GTK+ based e-mail client"
7 arch=('x86_64')
8 license=('GPL3')
9 url="https://www.claws-mail.org"
10 depends=('gtk3' 'gnutls' 'startup-notification' 'enchant' 'gpgme'
11          'libetpan' 'compface' 'libsm' 'dbus-glib')
12 makedepends=('spamassassin' 'bogofilter' 'networkmanager' 'valgrind'
13              # dependencies for plugins
14              'libgdata' 'libnotify' 'libcanberra' 'poppler-glib' 'libytnef' 'libical'
15              'dillo' 'python' 'gumbo-parser'
16              # deps to build the docs
17              'docbook-utils' 'texlive-formatsextra')
18 optdepends=('python:           needed for some tools'
19             'perl:              needed for some tools and perl plugin'
20             'spamassassin:      adds support for spamfiltering'
21             'bogofilter:        adds support for spamfiltering'
22             'libnotify:         for notification plugin'
23             'libcanberra:       for notification plugin'
24             'dbus:              for notification plugin'
25             'libxml2:           for rssyl plugins'
26             'curl:              for vcalendar, rssyl and spamreport plugins'
27             'libarchive:        for archive plugin and various other plugins'
28             'libytnef:          for tnef_parse plugin'
29             'libgdata:          for gdata plugin'
30             'poppler-glib:      for pdf viewer plugin'
31             'ghostscript:       for pdf viewer plugin'
32             'libical:           for vcalendar plugin'
33             'dillo:             for dillo html viewer plugin'
34             'webkit2gtk:        for fancy webkit html viewer plugin'
35             'gumbo-parser:      for litehtml plugin')
36 provides=('claws')
37 install=$pkgname.install
38 source=(https://www.claws-mail.org/download.php?file=releases/claws-mail-$pkgver.tar.xz{,.asc}
39         bash_completion
40         20cope_with_fix_for_1009149.patch)
41 sha256sums=('0e1a9ca0db8d2a9e058ae30cdc7fc919779214ec3c56ee0c8a7f88cc23817a8e'
42             'SKIP'
43             '3f6c248b8658cd7a62186bff572cce2525712a498f363cbbda1ed459021c28cb'
44             'fd606c966a05be36b6bf6184067b71bcdb46d08df1b64514a973b9825e69aaab')
45 validpgpkeys=('8B3B297A03468356692F8D592CD716D654D6BBD4') # Paul <paul@claws-mail.org>
46 #options=(!makeflags)
48 prepare() {
49   cd "${pkgname}"-${pkgver}
50   # Debian patch fixing build errors with recent gcc/perl versions
51   # https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1009473
52   patch -Np1 -i ../20cope_with_fix_for_1009149.patch
53 #  # upstream fixes
56 build() {
57   cd "${pkgname}"-${pkgver}
58   ./configure --prefix=/usr --disable-static \
59     --enable-enchant \
60     --enable-gnutls \
61     --enable-ldap \
62     --enable-crash-dialog \
63     --enable-pgpmime-plugin \
64     --enable-spamassassin-plugin \
65     --enable-bogofilter-plugin \
66     --enable-fancy-plugin \
67     --enable-manual
68   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
69   make
72 package() {
73   cd "${pkgname}"-${pkgver}
74   make DESTDIR="${pkgdir}" install
76   install -Dm 644 "$srcdir"/bash_completion "${pkgdir}"/usr/share/bash-completion/completions/claws-mail
78   # install extra tools
79   cd tools
80   install -m755 -d "${pkgdir}"/usr/lib/claws-mail/tools
81   for files in *.pl *.py *.sh *.conf tb2claws-mail update-po uudec uuooffice README; do
82     cp -arv $files "${pkgdir}"/usr/lib/claws-mail/tools/
83   done