OCaml 4.14.0 rebuild
[arch-packages.git] / eog-plugins / trunk / PKGBUILD
blobe0c19b86d0c3a90efe3291d965c6248443885a56
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgname=eog-plugins
4 pkgver=42.1
5 pkgrel=1
6 pkgdesc="Plugins for Eye of Gnome"
7 arch=(x86_64)
8 url="https://wiki.gnome.org/Apps/EyeOfGnome/Plugins"
9 license=(GPL2)
10 depends=(eog libchamplain libgdata python-gobject)
11 makedepends=(gobject-introspection git meson)
12 options=(debug)
13 _commit=f7a02a5ee12d0a1166c0cd34472e8009960da644  # tags/42.1^0
14 source=("git+https://gitlab.gnome.org/GNOME/eog-plugins.git#commit=$_commit")
15 sha512sums=('SKIP')
17 pkgver() {
18   cd $pkgname
19   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
22 prepare() {
23   cd $pkgname
26 build() {
27   arch-meson $pkgname build
28   meson compile -C build
31 check() {
32   meson test -C build --print-errorlogs
35 package() {
36   meson install -C build --destdir "$pkgdir"
39 # vim:set sw=2 et: