OCaml 4.14.0 rebuild
[arch-packages.git] / fribidi / trunk / PKGBUILD
blob804f094a6a7a91ddbf44ead298da7f4f6f39cda8
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Giovanni Scafora <giovanni@archlinux.org>
3 # Contributor: Nezmer <Nezmer@gmail.com>
5 pkgname=fribidi
6 pkgver=1.0.12
7 pkgrel=1
8 pkgdesc="A Free Implementation of the Unicode Bidirectional Algorithm"
9 url="https://github.com/fribidi/fribidi/"
10 arch=(x86_64)
11 license=(LGPL)
12 depends=(glibc)
13 makedepends=(git meson)
14 provides=(libfribidi.so)
15 options=(debug)
16 _commit=6428d8469e536bcbb6e12c7b79ba6659371c435a  # tags/v1.0.12^0
17 source=("git+https://github.com/fribidi/fribidi#commit=$_commit")
18 sha256sums=('SKIP')
20 pkgver() {
21   cd fribidi
22   git describe --tags | sed 's/^v//;s/[^-]*-g/r&/;s/-/+/g'
25 prepare() {
26   cd fribidi
29 build() {
30   arch-meson fribidi build \
31     -D docs=false
32   meson compile -C build
35 check() {
36   meson test -C build --print-errorlogs
39 package() {
40   meson install -C build --destdir "$pkgdir"
43 # vim:set sw=2 et: