1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Ionut Biru <ibiru@archlinux.org>
5 pkgname=(gdk-pixbuf2 gdk-pixbuf2-docs)
8 pkgdesc="An image loading library"
9 url="https://wiki.gnome.org/Projects/GdkPixbuf"
12 depends=(glib2 libpng libtiff libjpeg shared-mime-info)
13 makedepends=(gobject-introspection git meson gi-docgen docbook-xsl)
15 "libwmf: Load .wmf and .apm"
16 "libopenraw: Load .dng, .cr2, .crw, .nef, .orf, .pef, .arw, .erf, .mrw, and .raf"
18 "libheif: Load .heif, .heic, and .avif"
20 "librsvg: Load .svg, .svgz, and .svg.gz"
21 "webp-pixbuf-loader: Load .webp"
24 _commit=bca00032ad68d0b0aa2c1f7558db931e52bd9cd2 # tags/2.42.8^0
26 "git+https://gitlab.gnome.org/GNOME/gdk-pixbuf.git#commit=$_commit"
27 gdk-pixbuf-query-loaders.hook
30 '9fb71d95e6a212779eb0f88dde5a3cee0df7f4d9183f8f9ce286f8cdc14428f0')
34 git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
42 arch-meson gdk-pixbuf build \
43 -D builtin_loaders=all \
45 -D installed_tests=false
46 meson compile -C build
50 meson test -C build --print-errorlogs
53 package_gdk-pixbuf2() {
54 provides=(libgdk_pixbuf-2.0.so)
55 install=gdk-pixbuf2.install
57 meson install -C build --destdir "$pkgdir"
59 mkdir -p doc/usr/share
60 mv {"$pkgdir",doc}/usr/share/doc
62 install -Dt "$pkgdir/usr/share/libalpm/hooks" -m644 *.hook
65 package_gdk-pixbuf2-docs() {
66 pkgdesc+=" (documentation)"