OCaml 4.14.0 rebuild
[arch-packages.git] / glade / trunk / PKGBUILD
blobdd7bb778da86303bd8dd35ae683cab090d578b55
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Douglas Soares de Andrade <douglas@archlinux.org>
4 pkgname=glade
5 pkgver=3.38.2
6 pkgrel=3
7 pkgdesc="User Interface Builder for GTK+ applications"
8 url="https://glade.gnome.org/"
9 arch=(x86_64)
10 license=(GPL LGPL)
11 depends=(gtk3 libxml2)
12 makedepends=(gtk-doc gobject-introspection python-gobject itstool docbook-xsl
13              git webkit2gtk meson gjs)
14 checkdepends=(xorg-server-xvfb)
15 optdepends=('devhelp: development help')
16 groups=(gnome-extra)
17 provides=(libgladeui-2.so)
18 _commit=152031927c60c167ae7b035a78fca4d70678775c  # glade-3-38
19 source=("git+https://gitlab.gnome.org/GNOME/glade.git#commit=$_commit"
20         python-dep.diff)
21 sha256sums=('SKIP'
22             'dc1ed48403d473fcacef37fc6dd693e0442e7fed31bb852b20957c71595e2124')
24 pkgver() {
25   cd $pkgname
26   git describe --tags | sed 's/^GLADE_//;s/_/./g;s/-/+/g'
29 prepare() {
30   cd $pkgname
32   # Add missing tag
33   git tag -f GLADE_3_38_2 152031927c60c167ae7b035a78fca4d70678775c
35   # Fix build with Python 3.9
36   git apply -3 ../python-dep.diff
39 build() {
40   arch-meson $pkgname build -D gtk_doc=true
41   meson compile -C build
44 check() {
45   # Requires Glade to be installed to pass
46   # GladeUI-FATAL-CRITICAL: Unable to load image (Failed to open file "/usr/share/glade/pixmaps/plus.png": No such file or directory)
47   dbus-run-session xvfb-run \
48     -s '-screen 0 1920x1080x24 -nolisten local' \
49     meson test -C build --print-errorlogs || :
52 package() {
53   DESTDIR="$pkgdir" meson install -C build