1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Douglas Soares de Andrade <douglas@archlinux.org>
7 pkgdesc="User Interface Builder for GTK+ applications"
8 url="https://glade.gnome.org/"
11 depends=(gtk3 libxml2)
12 makedepends=(gtk-doc gobject-introspection python-gobject itstool docbook-xsl
13 git webkit2gtk meson gjs)
14 checkdepends=(xorg-server-xvfb)
15 optdepends=('devhelp: development help')
17 provides=(libgladeui-2.so)
18 _commit=152031927c60c167ae7b035a78fca4d70678775c # glade-3-38
19 source=("git+https://gitlab.gnome.org/GNOME/glade.git#commit=$_commit"
22 'dc1ed48403d473fcacef37fc6dd693e0442e7fed31bb852b20957c71595e2124')
26 git describe --tags | sed 's/^GLADE_//;s/_/./g;s/-/+/g'
33 git tag -f GLADE_3_38_2 152031927c60c167ae7b035a78fca4d70678775c
35 # Fix build with Python 3.9
36 git apply -3 ../python-dep.diff
40 arch-meson $pkgname build -D gtk_doc=true
41 meson compile -C build
45 # Requires Glade to be installed to pass
46 # GladeUI-FATAL-CRITICAL: Unable to load image (Failed to open file "/usr/share/glade/pixmaps/plus.png": No such file or directory)
47 dbus-run-session xvfb-run \
48 -s '-screen 0 1920x1080x24 -nolisten local' \
49 meson test -C build --print-errorlogs || :
53 DESTDIR="$pkgdir" meson install -C build