OCaml 4.14.0 rebuild
[arch-packages.git] / gnome-clocks / repos / extra-x86_64 / PKGBUILD
blobce37dde812f95453d49f6e3ac9af2452fd684ea6
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgname=gnome-clocks
4 pkgver=42.0
5 pkgrel=1
6 pkgdesc="Clocks applications for GNOME"
7 url="https://wiki.gnome.org/Apps/Clocks"
8 arch=(x86_64)
9 license=(GPL)
10 depends=(gtk4 libgweather-4 gnome-desktop-4 geoclue geocode-glib gsound
11          libadwaita)
12 makedepends=(vala gobject-introspection yelp-tools git meson)
13 groups=(gnome)
14 options=(debug)
15 _commit=53779868cc89b6347a2090025e81af6e70d7c14d  # tags/42.0^0
16 source=("git+https://gitlab.gnome.org/GNOME/gnome-clocks.git#commit=$_commit")
17 sha256sums=('SKIP')
19 pkgver() {
20   cd $pkgname
21   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
24 prepare() {
25   cd $pkgname
28 build() {
29   arch-meson $pkgname build
30   meson compile -C build
33 check() {
34   meson test -C build --print-errorlogs
37 package() {
38   meson install -C build --destdir "$pkgdir"