OCaml 4.14.0 rebuild
[arch-packages.git] / gnome-online-accounts / repos / extra-x86_64 / PKGBUILD
blob2dd0a85efe45d7eee2e51b7996b8dba3c2550ddb
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Ionut Biru <ibiru@archlinux.org>
4 pkgname=gnome-online-accounts
5 pkgver=3.44.0
6 pkgrel=1
7 pkgdesc="Single sign-on framework for GNOME"
8 url="https://wiki.gnome.org/Projects/GnomeOnlineAccounts"
9 arch=(x86_64)
10 license=(LGPL)
11 depends=(webkit2gtk json-glib libnotify rest libsecret krb5 gcr)
12 makedepends=(gobject-introspection gtk-doc vala git meson)
13 optdepends=('gvfs-goa: Virtual file systems, e.g. OwnCloud'
14             'gvfs-google: Google Drive')
15 provides=(libgoa-1.0.so libgoa-backend-1.0.so)
16 options=(debug)
17 _commit=568139a2ce9d3791bd90b2b431898f712821c817  # tags/3.44.0^0
18 source=("git+https://gitlab.gnome.org/GNOME/gnome-online-accounts.git#commit=$_commit")
19 sha256sums=('SKIP')
21 pkgver() {
22   cd $pkgname
23   git describe --tags | sed 's/-/+/g'
26 prepare() {
27   cd $pkgname
30 build() {
31   arch-meson $pkgname build \
32     -D media_server=true \
33     -D gtk_doc=true \
34     -D man=true
35   meson compile -C build
38 check() {
39   meson test -C build --print-errorlogs
42 package() {
43   meson install -C build --destdir "$pkgdir"
46 # vim:set sw=2 et: