1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Ionut Biru <ibiru@archlinux.org>
4 pkgname=gnome-online-accounts
7 pkgdesc="Single sign-on framework for GNOME"
8 url="https://wiki.gnome.org/Projects/GnomeOnlineAccounts"
11 depends=(webkit2gtk json-glib libnotify rest libsecret krb5 gcr)
12 makedepends=(gobject-introspection gtk-doc vala git meson)
13 optdepends=('gvfs-goa: Virtual file systems, e.g. OwnCloud'
14 'gvfs-google: Google Drive')
15 provides=(libgoa-1.0.so libgoa-backend-1.0.so)
17 _commit=568139a2ce9d3791bd90b2b431898f712821c817 # tags/3.44.0^0
18 source=("git+https://gitlab.gnome.org/GNOME/gnome-online-accounts.git#commit=$_commit")
23 git describe --tags | sed 's/-/+/g'
31 arch-meson $pkgname build \
32 -D media_server=true \
35 meson compile -C build
39 meson test -C build --print-errorlogs
43 meson install -C build --destdir "$pkgdir"