OCaml 4.14.0 rebuild
[arch-packages.git] / gnome-session / trunk / PKGBUILD
blob2324437ed59f0d8c74f8a4355a6b435fad1b30dd
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgname=gnome-session
4 pkgver=42.0
5 pkgrel=1
6 pkgdesc="The GNOME Session Handler"
7 url="https://gitlab.gnome.org/GNOME/gnome-session"
8 arch=(x86_64)
9 license=(GPL)
10 depends=(systemd dconf gsettings-desktop-schemas gnome-desktop json-glib libgl
11          libsm libxtst)
12 makedepends=(mesa gtk-doc xtrans git python xmlto docbook-xsl meson)
13 groups=(gnome)
14 options=(debug)
15 _commit=7040e3e595040698fc67ddffaa5be499958237ff  # tags/42.0^0
16 source=("git+https://gitlab.gnome.org/GNOME/gnome-session.git#commit=$_commit")
17 sha256sums=('SKIP')
19 pkgver() {
20   cd $pkgname
21   git describe --tags | sed 's/\.beta/beta/;s/[^-]*-g/r&/;s/-/+/g'
24 prepare() {
25   cd $pkgname
28 build() {
29   arch-meson $pkgname build
30   meson compile -C build
33 check() {
34   meson test -C build --print-errorlogs
37 package() {
38   meson install -C build --destdir "$pkgdir"