OCaml 4.14.0 rebuild
[arch-packages.git] / gnome-sound-recorder / trunk / PKGBUILD
blob90dc9b764fd45d3da9e3ef72233300ad34f0623d
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
4 pkgname=gnome-sound-recorder
5 pkgver=42.0
6 pkgrel=1
7 pkgdesc="A utility to make simple audio recording from your GNOME desktop"
8 url="https://wiki.gnome.org/Apps/SoundRecorder"
9 arch=(any)
10 license=(GPL)
11 depends=(gtk4 gjs gst-plugins-good gst-plugins-base gst-plugins-bad-libs
12          libadwaita)
13 makedepends=(gobject-introspection git meson)
14 groups=(gnome-extra)
15 _commit=0fabec18319c0baf0c627131c023f7c191af65d9  # tags/42.0^0
16 source=("git+https://gitlab.gnome.org/GNOME/gnome-sound-recorder.git#commit=$_commit")
17 sha256sums=('SKIP')
19 pkgver() {
20   cd $pkgname
21   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
24 prepare() {
25   cd $pkgname
28 build() {
29   arch-meson $pkgname build
30   meson compile -C build
33 check() {
34   meson test -C build --print-errorlogs
37 package() {
38   meson install -C build --destdir "$pkgdir"
41 # vim:set sw=2 et: