1 # Maintainer: David Runge <dvzrv@archlinux.org>
6 pkgdesc="Develop EFI applications using the GNU toolchain and the EFI development environment"
8 url="https://sourceforge.net/projects/gnu-efi/"
10 conflicts=(gnu-efi-libs)
11 provides=(gnu-efi-libs)
12 replaces=(gnu-efi-libs)
13 source=(https://download.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.bz2)
15 sha512sums=('37420ba3804e8547451a7b143a689ceb6af0557234fa7801efdeba3c2fc581a5354fe34cbaacb338d7b394d913e7274098ebf07026b7c1d50b2236d7f86c470c')
16 b2sums=('c7f9127d3bb7e5e2bc52f5fc7be3376ddc5076b262e5db5a30a997cf10bf10288da63ded64d11327fad09190a803ce26e82b32aea2d8525ee0d1e1a23ebadff2')
19 # -Werror, not even once
20 sed -e 's/-Werror//g' -i $pkgname-$pkgver/Make.defaults
25 # NOTE: apply only minimal CFLAGS, as gnu-efi does not provide userspace
26 # libs, but may be used in unitialized machine state and should therefore not
27 # be architecture optmized
28 # NOTE: fat-lto-objects is required for non-mangled (static) object files
29 CFLAGS="-O2 -flto -ffat-lto-objects"
34 # unset LDFLAGS for custom linker used in apps, as we have patched our
35 # LDFLAGS in manually in prepare()
42 make INSTALLROOT="$pkgdir" PREFIX=/usr install
43 install -vDm 644 apps/*.efi -t "$pkgdir/usr/share/$pkgname/apps/$CARCH/"
44 install -vDm 644 README.efilib -t "$pkgdir/usr/share/licenses/$pkgname/"
45 install -vDm 644 {ChangeLog,README.{gnuefi,git,elilo}} -t "$pkgdir/usr/share/doc/$pkgname/"