1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
6 pkgdesc="Clipboard management system"
7 url="https://www.imagination-land.org/tags/GPaste.html"
10 depends=(gtk3 gtk4 libadwaita)
11 makedepends=(vala appstream-glib gobject-introspection gnome-shell
12 gnome-control-center git meson)
13 optdepends=("wgetpaste: Upload clipboard contents")
15 _commit=5265371559fbd54426255938d5dd1172ddb4e92c # tags/v42.1^0
16 source=("git+https://github.com/keruspe/gpaste#commit=$_commit")
21 git describe --tags | sed 's/^v//;s/[^-]*-g/r&/;s/-/+/g'
29 arch-meson gpaste build
30 meson compile -C build
34 meson test -C build --print-errorlogs
38 meson install -C build --destdir "$pkgdir"
39 install -Dt "$pkgdir/usr/share/licenses/$pkgname" -m644 gpaste/COPYING