1 # Maintainer: AndyRTR <andyrtr@archlinux.org>
4 pkgname=('hyphen' 'hyphen-en')
8 url="https://hunspell.sf.net"
9 license=('GPL2' 'LGPL2.1' 'MPL')
10 makedepends=('glibc' 'perl')
11 source=(https://downloads.sourceforge.net/hunspell/${pkgname}-${pkgver}.tar.gz)
12 sha1sums=('0556c392beb59433e577e3517575801212201df6')
16 ./configure --prefix=/usr --disable-static
21 pkgdesc="library for high quality hyphenation and justification"
22 depends=('glibc' 'perl')
25 make DESTDIR="$pkgdir/" install-libLTLIBRARIES
26 make DESTDIR="$pkgdir/" install-binSCRIPTS
27 make DESTDIR="$pkgdir/" install-includeHEADERS
30 install -D -m644 COPYING "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
34 pkgdesc="English hyphenation rules"
36 optdepends=('hyphen: offers hyphenation library functions')
39 make DESTDIR="$pkgdir/" install-hyphDATA
41 pushd ${pkgdir}/usr/share/hyphen/
42 en_US_aliases="en_AG en_AU en_BS en_BW en_BZ en_CA en_DK en_GB en_GH en_HK en_IE en_IN en_JM en_NA en_NZ en_PH en_SG en_TT en_ZA en_ZW"
43 for lang in $en_US_aliases; do
44 ln -s hyph_en_US.dic hyph_$lang.dic
49 install -dm755 ${pkgdir}/usr/share/myspell/dicts
50 pushd "$pkgdir"/usr/share/myspell/dicts
51 for file in "$pkgdir"/usr/share/hyphen/*; do
52 ln -sv /usr/share/hyphen/$(basename $file) .