OCaml 4.14.0 rebuild
[arch-packages.git] / kemoticons / repos / extra-x86_64 / PKGBUILD
blob35f3cc01e806c08b8a45bed8f8656fda49af8114
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 # Contributor: Andrea Scarpino <andrea@archlinux.org>
5 pkgname=kemoticons
6 pkgver=5.96.0
7 pkgrel=1
8 pkgdesc='Support for emoticons and emoticons themes'
9 arch=(x86_64)
10 url='https://community.kde.org/Frameworks'
11 license=(LGPL)
12 depends=(karchive kservice)
13 makedepends=(extra-cmake-modules doxygen qt5-tools qt5-doc)
14 groups=(kf5)
15 source=(https://download.kde.org/stable/frameworks/${pkgver%.*}/$pkgname-$pkgver.tar.xz{,.sig})
16 sha256sums=('e5b823df8ea2e350877e652075830f17464600345b06ba66e05e99b67957650d'
17             'SKIP')
18 validpgpkeys=(53E6B47B45CEA3E0D5B7457758D0EE648A48B3BB) # David Faure <faure@kde.org>
19 options=(debug)
21 build() {
22   cmake -B build -S $pkgname-$pkgver \
23     -DBUILD_TESTING=OFF \
24     -DBUILD_QCH=ON
25   cmake --build build
28 package() {
29   DESTDIR="$pkgdir" cmake --install build