OCaml 4.14.0 rebuild
[arch-packages.git] / kigo / kde-unstable / PKGBUILD
blob344d9384b788807d78fb40856f856ba90a0b67e2
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 # Contributor: Andrea Scarpino <andrea@archlinux.org>
5 pkgname=kigo
6 pkgver=22.07.90
7 pkgrel=1
8 pkgdesc='An open-source implementation of the popular Go game'
9 url='https://apps.kde.org/kigo/'
10 arch=(x86_64)
11 license=(GPL LGPL FDL)
12 groups=(kde-applications kde-games)
13 depends=(libkdegames gnugo hicolor-icon-theme)
14 makedepends=(extra-cmake-modules kdoctools)
15 source=(https://download.kde.org/unstable/release-service/$pkgver/src/$pkgname-$pkgver.tar.xz{,.sig})
16 sha256sums=('b27f73952268a09680ee7514a3fb5a4aa8f7b2b6bbc84c67e341d734da9709a4'
17             'SKIP')
18 validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7  # Albert Astals Cid <aacid@kde.org>
19               F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87  # Christoph Feck <cfeck@kde.org>
20               D81C0CB38EB725EF6691C385BB463350D6EF31EF) # Heiko Becker <heiko.becker@kde.org>
21 options=(debug)
23 build() {
24   cmake -B build -S $pkgname-$pkgver \
25     -DBUILD_TESTING=OFF
26   cmake --build build
29 package() {
30   DESTDIR="$pkgdir" cmake --install build