OCaml 4.14.0 rebuild
[arch-packages.git] / kitemmodels / trunk / PKGBUILD
blobb49f316dd51b8122ecd898f81aa0927cbfa5a510
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 # Contributor: Andrea Scarpino <andrea@archlinux.org>
5 pkgname=kitemmodels
6 pkgver=5.96.0
7 pkgrel=1
8 pkgdesc='Models for Qt Model/View system'
9 arch=(x86_64)
10 url='https://community.kde.org/Frameworks'
11 license=(LGPL)
12 depends=(qt5-base)
13 makedepends=(extra-cmake-modules clang doxygen qt5-tools qt5-doc qt5-declarative)
14 optdepends=('qt5-declarative: QML bindings')
15 groups=(kf5)
16 source=(https://download.kde.org/stable/frameworks/${pkgver%.*}/$pkgname-$pkgver.tar.xz{,.sig})
17 sha256sums=('5b30a75b34e5d6fd39689f49b408af2e19c557454b4db0ffff07b4f5b673d3c8'
18             'SKIP')
19 validpgpkeys=(53E6B47B45CEA3E0D5B7457758D0EE648A48B3BB) # David Faure <faure@kde.org>
20 options=(debug)
22 build() {
23   cmake -B build -S $pkgname-$pkgver \
24     -DBUILD_TESTING=OFF \
25     -DBUILD_QCH=ON
26   cmake --build build
29 package() {
30   DESTDIR="$pkgdir" cmake --install build