OCaml 4.14.0 rebuild
[arch-packages.git] / layer-shell-qt / repos / extra-x86_64 / PKGBUILD
blobc405fafa7c84c205b1438fc9d02ec7907ce8ff77
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 pkgname=layer-shell-qt
4 pkgver=5.25.4
5 pkgrel=1
6 pkgdesc='Qt component to allow applications to make use of the Wayland wl-layer-shell protocol'
7 arch=(x86_64)
8 url='https://kde.org/plasma-desktop/'
9 license=(GPL LGPL)
10 source=(https://download.kde.org/stable/plasma/$pkgver/$pkgname-$pkgver.tar.xz{,.sig})
11 depends=(qt5-wayland)
12 makedepends=(extra-cmake-modules wayland-protocols)
13 groups=(plasma)
14 sha256sums=('2716f8adeff6edba422ca6690d2c710d04d4ad948a11fc5f02b48874ad45a85d'
15             'SKIP')
16 validpgpkeys=('E0A3EB202F8E57528E13E72FD7574483BB57B18D'  # Jonathan Esk-Riddell <jr@jriddell.org>
17               '0AAC775BB6437A8D9AF7A3ACFE0784117FBCE11D'  # Bhushan Shah <bshah@kde.org>
18               'D07BD8662C56CB291B316EB2F5675605C74E02CF'  # David Edmundson <davidedmundson@kde.org>
19               '1FA881591C26B276D7A5518EEAAF29B42A678C20') # Marco Martin <notmart@gmail.com>
20 options=(debug)
22 build() {
23   cmake -B build -S $pkgname-$pkgver
24   cmake --build build
27 package() {
28   DESTDIR="$pkgdir" cmake --install build