OCaml 4.14.0 rebuild
[arch-packages.git] / ldb / trunk / PKGBUILD
blobe37b46a802cbc650227050296f4f04f4ffd76806
1 # Maintainer: Tobias Powalowski <tpowa@archlinux.org>
2 # Contributor: Christian Hesse <mail@eworm.de>
3 # Contributor: Marco A Rojas <marquicus at gmail dot com>
5 pkgname=ldb
6 pkgver=2.5.2
7 pkgrel=2
8 epoch=2
9 pkgdesc='Schema-less, ldap like, API and database'
10 arch=('x86_64')
11 url="https://ldb.samba.org/"
12 source=(https://samba.org/ftp/${pkgname}/${pkgname}-${pkgver}.tar{.gz,.asc})
13 license=('GPL3')
14 depends=('talloc' 'libtevent.so' 'tdb' 'libtdb.so' 'popt' 'lmdb')
15 makedepends=('python' 'cmocka' 'docbook-xsl' 'tevent')
16 optdepends=('python: for python bindings')
17 provides=(libldb.so)
18 validpgpkeys=('9147A339719518EE9011BCB54793916113084025') # Samba Library Distribution Key <samba-bugs@samba.org>
19 sha512sums=('02ae1246f99d9b6d6b33c5030488aa46c6abb535b4da4b13799a62b49d32c490b7c088ef41c0bc5a1b2f7263c680faceb8033827834cb6f66916adcdb5be421c'
20             'SKIP')
22 build() {
23   cd ${pkgname}-${pkgver}
24   ./configure \
25     --prefix=/usr \
26     --disable-rpath \
27     --disable-rpath-install \
28     --bundled-libraries=NONE \
29     --builtin-libraries=replace \
30     --with-modulesdir=/usr/lib/ldb/modules \
31     --with-privatelibdir=/usr/lib/ldb
32   make
35 package() {
36   cd ${pkgname}-${pkgver}
37   make DESTDIR="${pkgdir}" install
40 # vim: ts=2 sw=2 et: