OCaml 4.14.0 rebuild
[arch-packages.git] / libkeybinder3 / trunk / PKGBUILD
blob45bc0a1692df1b7ea3bc994432cdaa1279651764
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Eric BĂ©langer <eric@archlinux.org>
3 # Contributor: speps <speps at aur dot archlinux dot org>
5 pkgname=libkeybinder3
6 pkgver=0.3.2
7 pkgrel=3
8 pkgdesc="A library for registering global keyboard shortcuts"
9 arch=('x86_64')
10 url="https://github.com/engla/keybinder/tree/keybinder-3.0"
11 license=('MIT')
12 depends=('gtk3')
13 makedepends=('gtk-doc' 'gobject-introspection')
14 optdepends=('lua-lgi: lua bindings')
15 source=(https://github.com/kupferlauncher/keybinder/releases/download/keybinder-3.0-v$pkgver/keybinder-3.0-$pkgver.tar.gz{,.sig}
16         libkeybinder3-gtk-doc.patch::https://github.com/kupferlauncher/keybinder/pull/18.patch)
17 sha1sums=('d23c12440b54cb0f40e7e876c22001dc7b5714b0'
18           'SKIP'
19           '32333351bda812c4449e943f7da860fe443a4d0a')
20 validpgpkeys=('2578ABA1F9023159DFF211B7368712C4D7A44445') # Ulrik Sverdrup <ulrik.sverdrup@gmail.com>
22 prepare() {
23   cd keybinder-3.0-$pkgver
24   patch -p1 -i ../libkeybinder3-gtk-doc.patch
27 build() {
28   cd keybinder-3.0-$pkgver
29   ./configure --prefix=/usr --enable-gtk-doc
30   make
33 package() {
34   cd keybinder-3.0-$pkgver
35   make DESTDIR="$pkgdir" install
36   install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/LICENSE