OCaml 4.14.0 rebuild
[arch-packages.git] / liburing / repos / extra-x86_64 / PKGBUILD
blob07df4ec9bb0665f25cf241347bc23f88e4d3e17d
1 # Maintainer: David Runge <dvzrv@archlinux.org>
2 # Contributor: Filipe LaĆ­ns (FFY00) <lains@archlinux.org>
4 pkgname=liburing
5 pkgver=2.2
6 _commit=dda4848a9911120a903bef6284fb88286f4464c9  # refs/tags/liburing-2.2^{}
7 pkgrel=1
8 pkgdesc="Linux-native io_uring I/O access library"
9 arch=(x86_64)
10 url="https://git.kernel.dk/cgit/liburing/"
11 license=(LGPL2.1 MIT)
12 depends=(glibc)
13 makedepends=(git)
14 provides=(liburing.so)
15 options=(debug)
16 source=(git+https://git.kernel.dk/liburing#commit=$_commit)
17 sha512sums=('SKIP')
19 build() {
20   cd $pkgname
21   ./configure \
22     --prefix=/usr \
23     --mandir=/usr/share/man
24   make
27 package() {
28   make DESTDIR="$pkgdir" install -C $pkgname
29   install -vDm 644 $pkgname/LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"