OCaml 4.14.0 rebuild
[arch-packages.git] / lprint / repos / extra-x86_64 / PKGBUILD
blobef6833fde3921a8a671bf1b4047088321e1795a8
1 # Maintainer: Andreas Radke <andyrtr@archlinux.org>
2 # Contributor: WorMzy Tykashi <wormzy.tykashi@gmail.com>
4 pkgname=lprint
5 pkgver=1.1.0
6 pkgrel=1
7 pkgdesc="Label Printer Application"
8 arch=('x86_64')
9 url="https://www.msweet.org/lprint/"
10 license=('Apache' 'custom')
11 depends=('pappl' 'libcups' 'libpng' 'libusb' 'pam')
12 source=("https://github.com/michaelrsweet/lprint/releases/download/v${pkgver}/${pkgname}-${pkgver}.tar.gz"{,.sig}
13         fix-systemd-installdir.patch)
14 #validpgpkeys=('845464660B686AAB36540B6F999559A027815955')  # "Michael R Sweet <michael.r.sweet@gmail.com>"
15 validpgpkeys=('9086C3CDC66C3F563CF8F405BE67C75EC81F3244') # "Michael R Sweet <msweet@msweet.org>"
16 sha256sums=('d40e353ac9f6b0de96974717255fa1df0f9655d37ef3f9a6f35b6391992daf73'
17             'SKIP'
18             '5afaf8dad1e766f0c99a27095e56face16d2eae681d576c395db5d3c3761d182')
20 prepare() {
21   cd ${pkgname}-${pkgver}
22   patch -Np1 -i ../fix-systemd-installdir.patch
25 build() {
26   cd ${pkgname}-${pkgver}
27   ./configure --prefix=/usr
28   make
31 check() {
32    cd "$pkgname-$pkgver"
33    #make -k check
36 package() {
37   cd ${pkgname}-${pkgver}
38   make DESTDIR="${pkgdir}" install
39   # add license + exception
40   install -m644 -Dt "${pkgdir}/usr/share/licenses/${pkgname}" {LICENSE,NOTICE}