OCaml 4.14.0 rebuild
[arch-packages.git] / nuspell / repos / extra-x86_64 / PKGBUILD
blob8fe28daaa65df168fd7aaba72d59382fee256390
1 # Maintainer: AndyRTR <andyrtr@archlinux.org>
2 # Conributor: Mélanie Chauvel (ariasuni) <perso at hack-libre dot org>
4 pkgname=nuspell
5 pkgver=5.1.0
6 pkgrel=2
7 pkgdesc='Fast and safe spellchecking C++ library'
8 arch=('x86_64')
9 url='https://nuspell.github.io/'
10 license=('LGPL3')
11 depends=('icu')
12 makedepends=('cmake' 'pandoc')
13 #makedepends=('cmake' 'ruby-ronn')
14 checkdepends=('catch2')
15 source=(${pkgname}-${pkgver}.tar.gz::"https://github.com/nuspell/nuspell/archive/v${pkgver}.tar.gz")
16 #        ${pkgname}-pandoc.patch::https://github.com/nuspell/nuspell/commit/5d4f685011b2.patch)
17 sha512sums=('08ce776d224c66ba4bdd8cb22943741f30e8e5ba03396bfef1db598321c9b0f8814dacffcb52287b3b669426c7b08e2c1a40323341a9ff9768a7187002e1d77a')
18 #            'SKIP')
21 # 1st rebuild enchant
22 # 2nd rebuild epiphany against nuspell/enchant that checkdepens on both
24 prepare() {
25   mkdir build
26   # temporarily use ronn - pandoc is unusable due to a separate haskell rebuild
27 #  patch -Rp1 -f -d ${pkgname}-${pkgver} <${pkgname}-pandoc.patch || /bin/true
30 build() {
31   cd build
32   cmake ../${pkgbase}-${pkgver} \
33     -DCMAKE_BUILD_TYPE=Release \
34     -DCMAKE_INSTALL_PREFIX=/usr \
35     -DCMAKE_INSTALL_LIBDIR=/usr/lib \
36     -DBUILD_SHARED_LIBS=ON
37   make
40 check() {
41   cd build
42   make test
45 package() {
46   cd build
47   make DESTDIR="$pkgdir" install