OCaml 4.14.0 rebuild
[arch-packages.git] / orca / repos / extra-any / PKGBUILD
blob628b18946d929939cb7c144eb7f215a1fcab3dde
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
3 # Contributor: William Rea <sillywilly@gmail.com>
5 pkgname=orca
6 pkgver=42.3
7 pkgrel=1
8 pkgdesc="Screen reader for individuals who are blind or visually impaired"
9 url="https://wiki.gnome.org/Projects/Orca"
10 arch=(any)
11 license=(LGPL)
12 depends=(
13   gtk3 at-spi2-atk python-atspi python-dbus python-xdg speech-dispatcher
14   liblouis brltty xorg-xmodmap gsettings-desktop-schemas
15   gst-plugins-base # playbin, audiotestsrc, basic decoders
16   gst-plugins-good # pulsesink, more decoders
18 makedepends=(itstool git yelp-tools)
19 groups=(gnome)
20 _commit=ce74a5a3cf926d6cbc5f830036541fd32fb414d5  # tags/ORCA_42_3^0
21 source=("git+https://gitlab.gnome.org/GNOME/orca.git#commit=$_commit")
22 sha256sums=('SKIP')
24 pkgver() {
25   cd $pkgname
26   git describe --tags | sed 's/ORCA_//;s/_/\./g;s/[^-]*-g/r&/;s/-/+/g'
29 prepare() {
30   cd $pkgname
31   NOCONFIGURE=1 ./autogen.sh
34 build() {
35   cd $pkgname
36   ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var
37   make
40 package() {
41   cd $pkgname
42   make DESTDIR="$pkgdir" install
45 # vim:set sw=2 et: