1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Mateusz 'mrlemux' Lemusisk mrlemux at gmail dotcom
3 # Based on the pcre package by Sébastien "Seblu" Luttringer
4 # Contributor: Allan McRae <allan@archlinux.org>
5 # Contributor: Eric Belanger <eric@archlinux.org>
6 # Contributor: John Proctor <jproctor@prium.net>
11 pkgdesc='A library that implements Perl 5-style regular expressions. 2nd version'
13 url='https://www.pcre.org/'
15 depends=('gcc-libs' 'readline' 'zlib' 'bzip2' 'bash')
16 source=("https://github.com/PhilipHazel/pcre2/releases/download/$pkgname-$pkgver/$pkgname-$pkgver.tar.bz2"{,.sig})
17 sha512sums=('00e7b48a6554b9127cb6fe24c5cacf72783416a9754ec88f62f73c52f46ed72c86c1869e62c91a31b2ff2cbafbbedabca44b3f1eb7670bc92f49d8401c7374e8'
19 validpgpkeys=('45F68D54BBE23FB3039B46E59766E084FB0F43D8') # Philip Hazel
28 --enable-pcre2grep-libz \
29 --enable-pcre2grep-libbz2 \
30 --enable-pcre2test-libreadline
41 make DESTDIR="$pkgdir" install
43 install -Dm644 LICENCE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
46 # vim:set ts=2 sw=2 et: