OCaml 4.14.0 rebuild
[arch-packages.git] / python-cffi / trunk / PKGBUILD
blobd3d430d51eca0a399eb6bad744aeaa6ffbefd9ab
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: lilydjwg <lilydjwg@gmail.com>
4 pkgname=python-cffi
5 pkgver=1.15.1
6 pkgrel=1
7 pkgdesc="Foreign Function Interface for Python calling C code"
8 arch=('x86_64')
9 url="https://cffi.readthedocs.org/"
10 license=('MIT')
11 depends=('python-pycparser')
12 makedepends=('python-setuptools')
13 checkdepends=('python-pytest-runner')
14 source=("https://foss.heptapod.net/pypy/cffi/-/archive/v$pkgver/cffi-v$pkgver.tar.bz2")
15 sha512sums=('4505c1e3206b66fbdf06ba39be6daac14a35f7148cef3156bb2015792cb59c004ea13fe7c7514feb35ecc5e7526a88fc0b3036ae84fd146a0a3b55bc676e8e51')
17 build() {
18   cd "$srcdir"/cffi-v$pkgver
19   python setup.py build
22 check() {
23   cd "$srcdir"/cffi-v$pkgver
24   python setup.py pytest
27 package() {
28   cd cffi-v$pkgver
30   # remove files created during check() for reproducible SOURCES.txt
31   rm -rf testing/cffi{0,1}/__pycache__/
33   python setup.py install --root="$pkgdir" --optimize=1
34   install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE