OCaml 4.14.0 rebuild
[arch-packages.git] / qt5-gamepad / trunk / PKGBUILD
blobd3bef294f44fcddc9464cabacd1057aa4c195418
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Maintainer: Antonio Rojas <arojas@archlinux.org>
4 pkgname=qt5-gamepad
5 _qtver=5.15.2
6 _basever=5.15.5
7 pkgver=5.15.5+kde+r0
8 pkgrel=1
9 _commit=5107ddf28177112cdbf505f92bb4191a91e6521a
10 arch=('x86_64')
11 url='https://www.qt.io'
12 license=('GPL3' 'LGPL3' 'FDL' 'custom')
13 pkgdesc='Adds support for getting events from gamepad devices'
14 depends=('qt5-base' 'sdl2')
15 makedepends=('qt5-declarative' 'git')
16 optdepends=('qt5-declarative: QML bindings')
17 groups=('qt' 'qt5')
18 _pkgfqn=${pkgname/5-/}
19 source=(git+https://invent.kde.org/qt/qt/$_pkgfqn#commit=$_commit)
20 sha256sums=('SKIP')
21 options=(debug)
23 pkgver() {
24   cd $_pkgfqn
25   echo "$_basever+kde+r"`git rev-list --count v$_basever-lts-lgpl..$_commit`
28 prepare() {
29   mkdir -p build
32 build() {
33   cd build
35   qmake ../${_pkgfqn}
36   make
39 package() {
40   cd build
41   make INSTALL_ROOT="$pkgdir" install
43   # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
44   find "$pkgdir/usr/lib" -type f -name '*.prl' \
45     -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
47   install -d "$pkgdir"/usr/share/licenses
48   ln -s /usr/share/licenses/qt5-base "$pkgdir"/usr/share/licenses/${pkgname}