OCaml 4.14.0 rebuild
[arch-packages.git] / seahorse / repos / extra-x86_64 / PKGBUILD
blobe9d087c08795bde44cce8bf420dc32cbfcb50069
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Jan de Groot <jgc@archlinux.org>
3 # Contributor: Michel Brabants <michel.linux@tiscali.be>
5 pkgname=seahorse
6 pkgver=42.0
7 pkgrel=1
8 epoch=1
9 pkgdesc="GNOME application for managing PGP keys."
10 url="https://wiki.gnome.org/Apps/Seahorse"
11 arch=(x86_64)
12 license=(GPL)
13 depends=(gtk3 gcr libsecret libsoup gpgme org.freedesktop.secrets libpwquality
14          libhandy)
15 makedepends=(libldap yelp-tools gobject-introspection vala git meson)
16 provides=(x11-ssh-askpass)
17 options=(debug)
18 _commit=e16028469dc1ee3c627c2fd9d3a8df7955dc38ec  # tags/42.0^0
19 source=("git+https://gitlab.gnome.org/GNOME/seahorse.git#commit=$_commit")
20 sha256sums=('SKIP')
22 pkgver() {
23   cd seahorse
24   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
27 prepare() {
28   cd seahorse
31 build() {
32   arch-meson seahorse build -D manpage=true
33   meson compile -C build
36 check() {
37   meson test -C build --print-errorlogs
40 package() {
41   meson install -C build --destdir "$pkgdir"