OCaml 4.14.0 rebuild
[arch-packages.git] / speexdsp / trunk / PKGBUILD
blob31b559de7f6461fa29567485d415f27e15d3d14d
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgname=speexdsp
4 pkgver=1.2.1
5 pkgrel=1
6 pkgdesc="DSP library derived from Speex"
7 url="https://www.speex.org/"
8 arch=(x86_64)
9 license=(BSD)
10 depends=(gcc-libs)
11 makedepends=(git)
12 provides=(libspeexdsp.so)
13 options=(debug)
14 _commit=1b28a0f61bc31162979e1f26f3981fc3637095c8  # tags/SpeexDSP-1.2.1^0
15 source=("git+https://gitlab.xiph.org/xiph/speexdsp.git#commit=$_commit")
16 b2sums=('SKIP')
18 pkgver() {
19   cd speexdsp
20   git describe --tags | sed 's/^SpeexDSP-//;s/[^-]*-g/r&/;s/-/+/g'
23 prepare() {
24   cd speexdsp
25   ./autogen.sh
28 build() {
29   cd speexdsp
30   ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
31     --disable-static
32   sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
33   make
36 check() {
37   cd speexdsp
38   make -k check
41 package() {
42   cd speexdsp
43   make DESTDIR="$pkgdir" install
44   install -Dt "$pkgdir/usr/share/licenses/$pkgname" -m644 COPYING