OCaml 4.14.0 rebuild
[arch-packages.git] / template-glib / trunk / PKGBUILD
blob37fac488224a1d5cd22e32009aee33aef759711d
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
3 pkgname=template-glib
4 pkgver=3.34.1
5 pkgrel=1
6 pkgdesc="A templating library for GLib"
7 url="https://gitlab.gnome.org/GNOME/template-glib"
8 arch=(x86_64)
9 license=(LGPL)
10 depends=(glib2 gobject-introspection-runtime)
11 makedepends=(git meson vala gobject-introspection gtk-doc)
12 provides=(libtemplate_glib-1.0.so)
13 options=(debug)
14 _commit=5d2b2e9c9fc26e687cb2b0720eaae620d66e54a3  # tags/3.34.1^0
15 source=("git+https://gitlab.gnome.org/GNOME/template-glib.git#commit=$_commit")
16 sha256sums=('SKIP')
18 pkgver() {
19   cd $pkgname
20   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
23 prepare() {
24   cd $pkgname
27 build() {
28   arch-meson $pkgname build -D enable_gtk_doc=true
29   meson compile -C build
32 check() {
33   meson test -C build --print-errorlogs
36 package() {
37   meson install -C build --destdir "$pkgdir"