upgpkg: ocaml-ctypes 0.20.2-1
[arch-packages.git] / gnome-software / trunk / PKGBUILD
blob5de424f48b84ff45c9cc52292ed592a3aacd1d8d
1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Fabian Bornschein <fabiscafe-cat-mailbox-dog-org>
3 # Contributor: Jan de Groot <jgc@archlinux.org>
4 # Contributor: Yosef Or Boczko <yoseforb@gnome.org>
6 pkgname=gnome-software
7 pkgver=44.1
8 pkgrel=2
9 pkgdesc="GNOME Software Tools"
10 url="https://wiki.gnome.org/Apps/Software/"
11 arch=(x86_64)
12 license=(GPL)
13 depends=(
14   appstream
15   gsettings-desktop-schemas
16   gtk4
17   libadwaita
18   libsoup3
19   libsysprof-capture
20   libxmlb
21   polkit
23 makedepends=(
24   docbook-xsl
25   flatpak
26   fwupd
27   git
28   gobject-introspection
29   gtk-doc
30   libglib-testing
31   malcontent
32   meson
34 optdepends=(
35   'flatpak: Flatpak support plugin'
36   'fwupd: fwupd support plugin'
37   'malcontent: Parental control plugin'
39 groups=(gnome)
40 _commit=9afc9643998f39817b9c70f772535178da45b95d  # tags/44.1^0
41 source=(
42   "git+https://gitlab.gnome.org/GNOME/gnome-software.git#commit=$_commit"
43   "git+https://gitlab.gnome.org/mwleeds/gnome-pwa-list.git"
45 b2sums=('SKIP'
46         'SKIP')
48 pkgver() {
49   cd $pkgname
50   git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
53 prepare() {
54   cd $pkgname
56   git submodule init
57   git submodule set-url subprojects/gnome-pwa-list "$srcdir/gnome-pwa-list"
58   git -c protocol.file.allow=always submodule update
61 build() {
62   local meson_options=(
63     -D packagekit=false
64   )
66   arch-meson $pkgname build "${meson_options[@]}"
67   meson compile -C build
70 # Not running tests - need root and a D-Bus system bus
72 package() {
73   meson install -C build --destdir "$pkgdir"
76 # vim:set sw=2 sts=-1 et: