upgpkg: ocaml-ctypes 0.20.2-1
[arch-packages.git] / kalzium / trunk / PKGBUILD
blobd09a571a6bfa1a3e84841ebdddca86adbef6b00a
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Maintainer: Felix Yan <felixonmars@archlinux.org>
4 pkgname=kalzium
5 pkgver=23.04.1
6 pkgrel=1
7 pkgdesc='Periodic Table of Elements'
8 url='https://apps.kde.org/kalzium/'
9 arch=(x86_64)
10 license=(GPL LGPL FDL)
11 depends=(kparts knewstuff kplotting kunitconversion qt5-script avogadrolibs-qt5 openbabel hicolor-icon-theme)
12 makedepends=(extra-cmake-modules kdoctools eigen ocaml facile python)
13 groups=(kde-applications kde-education)
14 source=(https://download.kde.org/stable/release-service/$pkgver/src/$pkgname-$pkgver.tar.xz{,.sig})
15 sha256sums=('8339372d2438aae4b79218080c705ec971fbe5aa74cfc3e0f3316e53b48b1be9'
16             'SKIP')
17 validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7  # Albert Astals Cid <aacid@kde.org>
18               F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87  # Christoph Feck <cfeck@kde.org>
19               D81C0CB38EB725EF6691C385BB463350D6EF31EF) # Heiko Becker <heiko.becker@kde.org>
21 build() {
22   cmake -B build -S $pkgname-$pkgver \
23     -DBUILD_TESTING=OFF
24   cmake --build build
27 package() {
28   DESTDIR="$pkgdir" cmake --install build